Clutch wont engage

after putting in my new tranny and my new spec 3 the clutch wont engage any sol?

or things i should try ive tried bleeding the lines but that didnt work its just like a dead pedal

check that the lines not kinked maybe… i dunno…

dead pedal? as in it doesn’t come back up? definitely sounds like there is air in the line somewhere. How are you bleeding it? You tried using a mightyvac on it yet?

mighty vac?

i just unplug the line and pump the pedal and its not dead it comes back up just like theres no clutch

i tested it to when there was no trany it acts the same just like theres no clutch

Bump if fixed? Sound’s like no pressure from the pedal

its the damn slave cylinder got a new one be here monday!

Krux are you in mn?

Currently in WI

did you ever live in mn?

what color zx2 you got

ok that makes sense, glad you figured it out! let us know how it goes :slight_smile:

started the car 5 mins ago Whooo!
hopefully drive it tomorrow

nice man!

i’m about to go do the timing belt on mine so i can drive it lol.

haha well im not totaly done but damn i feel like driving it haha

have fun with a timinng belt haha theres a shop by my house that dose em for 100 bux with tha belt

for porsches? that’s pretty inexpensive :stuck_out_tongue:

actually i do need to do the timing belt on the zx2 as well…

haha ahhh i see on your Porsche